Display Driver Crash


#1

Title:
Display Driver Crash

Summary:
Upon trying to load a new 3d character, that is not the main menu character or Grave or Jaina, my computer’s display driver crashes and upon recovering, the game is crashed on a blank white screen.

Steps to reproduce:

  1. Go to local or practice mode
  2. Try to change to any character other than the defaults
  3. Game crash

Expected Results:
Being able to load a character

Actual Results:
GPU crash

Notes:
I’ve changed the settings all the way to lowest, turned off vsync, lowered the resolution substantially, and it’s still happening.
This has only begun happening since I had to start using my old GPU again, having bricked my good one, so it’s obviously a GPU/driver issue.

Attachments:
Output log
https://pastebin.com/jX83QfMT

Game Version:
v0.15956

System Information:
AMD Radeon HD 5870 – Driver: 15.200.1062.1004
16GB RAM
Gigabyte AX370-Gaming 5
AMD Ryzen 5 1600


#2

Please help, I can’t play :frowning:


#3

Over a month later, has this bug been looked at?


#4

It’s fairly hard for me to figure out what’s going on there, since I can’t reproduce this problem on the machines I have access to, and the log file doesn’t contain much that would help, hmm.

I don’t personally know of any specific dangerous driver interactions with our game, and the low-level graphics code is essentially Unity’s. At this point I can only guess at generic advice like using a different driver, or messing with NVidia’s control panel for this game, sorry.


#5

I did do more testing, I can load any character on the main menu except Geiger, (so, picking for quick match), but if I go to local play, trying to load any character crashes the game. I tried playing arcade, and I got half-way through a match as Midori vs Setsuki before it gave up and crashed.

I know it’s an old gpu, but it can run almost anything else just on low. I don’t understand why this game in particular would be causing crashes, and only in specific situations.


#6

Try adding either of these as “launch options” for the game (r-click on “Fantasy Strike” in Steam > Properties > General > Set Launch Options):

-force-glcore
or
-force-d3d9

This will try to run the game using OpenGL Core or DirectX 9, rather than the game’s default of DirectX 11, which may work better on your machine.


#7

I have the EXACT same problem. Similar graphics card too, an AMD Radeon HD 6800. I can run the game at 60 fps on the highest settings, but still get the crash unfortunately.

I tried the two commands. Adding -force-d3d9 does nothing. Adding -force-glcore actually fixes the problem, but causes horrible frame drops making the game unplayable. Are there any other things we can try to fix it? Thanks in any case for looking into this!


#8

After the new update, does it still have the same problem?