[Free Weekend] First 10 minutes experience

  1. The controller mapping screen uses a playstation layout and button labeling, even though I’m using an XBox controller. I suppose that given enough time I’ll remember what the square and circle and triangle map to, but in the meantime, it’s irritating.

  2. The Left Joystick does not work for movement, instead I need to use the DPad. The controller layout picture shows that the joystick can be used for movement, and I would much prefer it if this would work, I never use the DPad for movement in any other game.

  3. I cannot find an explanation of how to play, either within the game or in the forums. I can find all the button mappings, but no explanation of how the game is actually played. What is a special move or a super, do I need to accumulate some sort of resource in order to use one, if so how do I earn that resource, how do the health bars work (they look like maybe they’re just a counter from 1 to 5?), etc. If this information exists somewhere, I’d like to know where to get it, but more importantly, it should be obvious where to get it for someone that’s trying the game for the first time this weekend.

  1. Yes of course. We are pre-alpha and simply haven’t gotten to support icons for other controllers. Note that the entire step where you map to the PS4 buttons at all is a temp thing. Eventually, this step will happen automatically through no action of your own.

  2. Left stick should work. We’ve used it plenty, so if it’s not working, that is news to us and a bug. I just tested with both ps4 and xbox one controllers and left stick worked for me, so idk.

  3. There is a guide at the top of this website. fantasystrike.com/guide


Thanks David.

The link that you supply is not the same link that’s at the top of the page-- I did see that link and had clicked on it. The link at the top of the page leads to the URL http://fantasystrike.com/guide/index.php/Main_Page

I’ll fool around with my xbox controller some more. I did start and stop the client and retry it before reporting the issue, I’ll verify that it’s working in other games (it was as of two weeks ago, but who knows).

I can’t explain that. The link at the top of the page and the link I gave both lead to the same place for me.

If a controller doesn’t seem to work with our game, try closing the app, then plugging in the controller, then opening the game. Hold any two buttons (though…not the button that launches the Fig link, sorry about that) and set up the controller to match PS4 stuff. The expected result is that the left stick “just works”. And again, in the future, none of those steps will even be necessary.

  1. Left stick
    When I configure the controller (hold two buttons at any menu screen), I get to press up/down/left/right on either the pad or stick, and that’s what worked afterwards. Give that a try.

In both Chrome and Internet Explorer (on Windows), if you type in “www.fantasystrike.com/guide”, you get the guide for playing the video game.

In both Chrome and Internet Explorer (on Windows), if you type in “fantasystrike.com/guide”, you get sent to the Main_Page guide for the various Fantasy Strike tabletop games.

The link you supplied in your response leads to the correct place, because it is www.fantasystrike.com/guide

The link at the top of the page leads to the wrong place, because it is fantasystrike.com/guide

I verified this behavior by clearing my browser cache and typing in the URLs by hand.


I can’t reproduce that. It works for me now and has worked for many months. The DNS is set correctly.

Verifying that I get the same problem with the link that AndrewGR does. If the URL of that link is set to “fantasystrike.com/guide” instead of “http://www.fantasystrike.com/guide” it should be changed to the latter.

Also, the “Media” and “News” sections at the top of the forum are broken links for me; I suspect for the same reason.

I cannot reproduce the URL Guide problem on my Android tablet, nor can I reproduce it on my work laptop. However, it continues to reproduce 100% of the time on my home desktop. I also reproduced it in Edge. Both my dekstop and laptop are running the latest version of Windows 10.

1 Like

Downloaded, tried practice mode, had ~20 frame delay on my wireless keyboard, so no feedback possible :frowning:

I have a noticeable lag between inputs and what’s on screen from my laptop’s keyboard and the fps hovers around single digits. I was hoping it would be able to play this game.

Dang, that’s unfortunate! I can get it running at a just barely acceptable level by dropping graphics to Lowest at the lowest resolution, but even then it’s not perfect for me…

Apparently there’s still lots of room for optimization, I hear.

1 Like