Controller D-pad Issues


#1

Summary:

Since the last March Update, my direction inputs from my controller have been been acting weird. Initially, Down and Right would work correctly, but Left would function as Up, and Up would not work. It was the same in both menus and gameplay. I tested the inputs in my computer settings and tested the controller in an other game without problems. I restarted my computer as well, but no good. I re-binded the controller inputs in the game afterward but now there’s different issues. Down and Right work fine still, but Up and Left acted with different direction inputs.

The controller has had no issues with game prior. I’ve been playing since the game came out on steam with the same controller.

I’m using a third party X-Box one controller, by PDP.

I’m operating on Window’s 8.1 with a Lenovo Laptop.


#2

That is pretty surprising to me, my own Xbox One controller still works fine.

There are two things you can do to configure your controller: the first step is to hold any two buttons on the main menu to bind physical buttons to PS4 buttons, and the other step if needed is to go to the menu -> Button Config and assign which PS4 buttons correspond to which gameplay actions. Can you confirm you did the first step, about holding any two buttons on the main menu?


#3

Alternatively, can you make sure you don’t secretly have a second gamepad plugged into your computer? On Windows, “Set up USB game controllers” is what will show the list of plugged-in gamepads.


#4

I seem to have this issue since [re-installing my operating system] January, if I leave my controller plugged in when my computer starts up. If I replug, or just put it in after, it works fine.


#5

Issue seems to be resolved, but don’t know why. I didn’t further check controller settings, just rebound the controller like Thelo said, but I feel like that should worked earlier when I rebound from options.

Early today I did notice a Demo Mode in the front menu. Didn’t think much of it until now. It’s no longer there.

I’ll let you know if I can reproduce.


#6

“Demo Mode” shows up if Event Mode is enabled in the debug settings. No idea how that could get modified without you noticing it, though!


#7

Wait, I think I might have set off the event option while trying to navigate the menu.

Sorry.