[OS X] PS4 controller stops working if cmd-tabbing to another window

Title: OS X controller no longer recognized if cmd-tabbing to another app on the same monitor
Summary: if I cmd-tab to another window on the same monitor as Fantasy Strike and then cmd-tab back, I get a new controller dialog

Steps to reproduce:

  1. start game in arcade mode. I’m using a PS4 controller
  2. verify controller works as player 1 (I’ve used arcade mode)
  3. pause game
  4. cmd-tab to Steam.app on same monitor
  5. cmd-tab to FS_Mac

Expected Results:
I will get to continue to play as player 1

Actual Results:
I get a dialog asking me to “Press each button in sequence as indicated below” - I cannot actually use this to get my PS4 controller to continue working.

Notes:
I am able to continue playing if I switch to my keyboard.
If I select the local play option, the PS4 controller will be controlling player 2.
This is sometimes reproducible if I cmd-tab to my secondary monitor but is less reliable

Attachments:
23%20PM
This is the list of USB devices, in case that’s relevant

Game Version:
v1.18422

System Information:
Mac OS X 10.14.6
PS 4 controller (model CUH-ZCT2U)

I can confirm this.
I have the same issue.

The strange thing is that the controller is still working in the menu. You actually become player 2 and you’d have to use the keyboard to continue as playing player 1.
Somehow using the keyboard makes the game think you’d want to play with that in stead of the controller you set up.

I also tried connecting to my iMac, running macOS Mojave 10.14.6, using bluetooth, but I wasn’t able to set-up that properly. I don’t think that has anything to do with the game though.
Can someone with an older macOS version or with Catalina test this? Maybe it has something to do with 10.14.6.
I also have v1.18422 of FS.

I tested this on my laptop, the behavior is the same.

OS: Catalina (10.15.2)
FS: 1.18422
same controller

That’s not good.
So it’s not macOS then.
I will test this later this week on my iMac while I’m booted into Windows. I recently installed Fantasy Strike there as well. I’ll be able to double check if it’s a hardware thing.

As I was trying to show the problem under macOS to a friend just now, I wasn’t able to reproduce the problem anymore. At first I have connected 2 Dual Shock controllers by cable and that worked fine. Later we tried it with only one connected and the switching between players didn’t occur in Arcade Mode anymore.
I do not know how this is helpful, but at my side the problem seems fixed. I still have the same version of the game and I believe the same steam version, but could you do a retry anyway @DonnieSharko?