Random frame rate drops


#1

Random frame rate drops

Frame rate drops every now and again across all modes of FS, for no discernible reason.

Steps to reproduce:

  1. Play Fantasy Strike, turn on FPS display option to be sure
  2. Play in any mode… every now and again it will feel bad and sluggish and watch…
  3. The FPS has droped from around 60fps to 30fps.

Expected Results:
Stable FPS.

Actual Results:
FPS randomly drops.

Notes:
This issue has occured on most of the last few builds for months. My PC is way overpowered to run FS (runs SFV fine in max settings if I want to for example.

Attachments:

Game Version:
Current Wild West or Steam builds (Feb 9th 2018)

System Information:
image

Nvidia GeForce GTX 980M


#2

Ok I just tried to get a video of this happening… and I got my cleanest session ever. I am even more puzzled now as to the actual source of it…


#3

Ok just played for an hour all kinds of modes with only momentary frame drops trying to reproduce this. Finally got it to happen, Rook vs Sets, Morning Star Sanctuary stage soon after both characters had done a super. FPS stayed at around 30fps for 3-4 seconds afterwards.

Online match search was in progress too. I am really not sure what factor it is that causes it… guess I’ll have to play a lot of FS to try to give you more pointers though :smiley:


#4

vsync tries to lock to 60, but if your frames drop too low, it locks to 30 instead. Try turning vsync off.


#5

It’s vsync. By the nature of how vsync works, unrelated to anything in our game, if you have it on then when fps is 60 or above, it clamps to 60. So if fps was 61 or 10,000, it would become 60. And if fps is between 30 and 59, then it will clamp to 30. So if your computer’s power happens to be such that at a given resolution, at a given graphics setting, you are dropping below 60 and you have vsync on, then yes it will clamp to 30.

So the remedy here is either turn off vsync and deal with the screen tearing that causes (on all computers, this is unrelated to our game) or keep vsync on and choose lower resolution and/or lower graphics quality such that you always stay above 60fps.


#6

I will try it without v-sync… but I never get this in other far more demanding games graphically… so it’s still very odd.


#7

Wait what do you mean you don’t get it in other games? What we’re describing here is the technical nature of how vsync works. If you are playing another game, and vsync is on, and it’s at 58fps, then yes you really do get 30fps.


#8

Yes but without V-sync on, FS runs normally in the 100s of fps range. I will have t do a test and see what happens. Something in FS must REALLY kill my computer for it to drop below 60fps, no other game I play regularly (that runs at 60fps at least) has done that!


#9

Ok testing this on the lastest WW build with V-sync off my frame rate is always 150-250 during gameplay… however turning V-sync on I didn’t get any random slow down on the lastest WW build EITHER. So hopefully whatever issue I was getting has been fixed by incremental perfomance improvements or the updates to Unity.