Friend Matches are broken

Friend Matches are broken

I couldn’t play with my friend. We couldn’t see each other moving the cursor, the match wouldn’t start and we couldn’t even disconnect.

Steps to reproduce:

  1. Send a challange to a friend.
  2. Have him accept.

Expected Results:
We select our characters and play.

Actual Results:
I can pick my character, but I can’t see my opponent doing the same. The match wouldn’t start and it’s impossible to disconnect.

I happened multiple times, both with me and him inviting. I have nobody else to test this with though.


Game Version:
v10983 (Steam Early Access)

System Information:
Windows 10 64 bit, both.

EDIT: I’ve tried with another friend too (@Legion). We could start the match but it would desync immediately. A second time he could select the character but I couldn’t move the cursor. He is on Windows 8.

confirmed, we tried friend challenging several times and everyime the match crashed

EDIT 2: I ended up playing with @Legion just fine later on. Not sure how.


We’ve been working on fixes for desyncs intermittently during the day; we won’t stop until they’re all gone! Sorry if you guys are having trouble getting matches but it’s the utmost priority for our team making sure the game is actually playable online. Thanks for your patience.


A related but similar issue that might be linked to this:

We discovered yesterday (steam early access) that you can break friend matches by doing the following steps:

  1. Go to the friends screen and invite a friend.

  2. Before the friend accepts the invite, back out of the friends screen to the main menu.

  3. When the friend accepts the invite, it will take a lot longer than usual for “Here comes a new challenger!” to pop up.

  4. When the character select screen comes up, you can select your character, but you never see your friend’s cursor move or selections. You can’t even disconnect from within the game to get back to the main menu; I had to quit it from the Windows close button to quit the game and try again.

We were able to reproduce this on both of our ends. As long as we stayed in the Friends screen when sending invites, everything worked.

1 Like

Dude that’s exactly what’s happening to us. Proiblem is that when the other guy accepts, we get back to the main menu automatically.

There must be something relating to the status of setting up the match depending on the location of either the host or the guest in the game when sending or accepting the invite. It’d take some work to suss out all the combinations, but I’ve got a good hunch that’s it. Do you happen to remember where you were within the game sending or accepting invites?

I think sticking in the friends screen is probably the safest bet at this point as I only had problems when going outside the friends screen. As long as I was there, my group of friends and I were able to match up no problem.

We tried with both me sending and receving, but neither worked.

And I belive you that remaining in the friend screen would probably solve it, too bad we get sent to the main menu each time the challange is accepted. :frowning:

Also, I’ve got extra news: after I got sent back to the main menu, I don’t seem to be able to connect to the serves for a quick match.

I’m not sure if it’s normal.

update: still broken.

Whenever i try to have a friend match we both get stuck at the char selection screen. It is impossible to disconnect and the game has to be rebooted.

We’ll have to wait for the next update I belive.

i just tried challenges with @ThreeHeadedMonkey he would get dc, i would find myself in a mirror match

meaning my cursor would move both players, and if i pressed start game i would play against my mirros (identical inputs at the same time)

Also my friend that couldn’t connect to QM before the update is still having issues now :frowning:

I think I have found a workaround for friend matches not working. It seems to be dealing with the funkiness with the main menu (and all of its submenus). Three of us were not able to connect to friend matches. I have the lowest spec computer of the three of us. But, none of us could connect to each other. However, I went into arcade mode and challenged from there while I was in a match against the CPU. I was able to connect every time. Every time I have trouble connecting in a friend match, I challenge from within the Arcade. It seems that since the game runs so much smoother in arcade mode that it doesn’t have as many issues when challenging in friend matches. This workaround also worked for both of my friends.

Kind of weird, but it’s worth a shot!

Quite honestly, the only reason I even had the idea of doing so is because in the main menu and other areas I typically run in single digit FPS or barely double digit. But, in arcade I run at least 60fps (offline anyway). So it occurred to me that my computer wouldn’t have to work as hard to connect when I challenged from in there. Worked every time so far. Especially since I consistently have problems connecting in friend matches.

Welp, didn’t work. One day…

Dang… hmm. Both of you were in arcade mode as well?

Yep, we were.