Just bought game on Steam and it won't launch

I bought the game yesterday, but haven’t been able to launch it yet.

I’ve tried:
To press “Play” on steam. It loads for a few seconds, then flashes a window that appears like the FS logo with a big red “!” on it (but disapppears before I can read anything)

I’ve tried reinstalling the game a couple of times with no result.

Tried running the game from game folder as “administrator”.

EDIT: wanted to attach log file, but forum couldn’t find a way to attach txt files. This log file references a “Crash” folder in the Fantasy Strike folder, but the Crash folder doesn’t seem to be there.

System information:
Lenovo Legion Y520 with 16GB RAM, i5-7300HQ CPU 2.5GHz, nvidia Geforce GTX 1050 TI
Windows 10 Home 64-bit
All drivers updated

I’ve written this on the Discord server as welll, but thought to post here as well in case others had the same issue and were looking here. Hope that’s ok. Let me know if you need me to test anything from here.

My first reflex is to check for an antivirus system that could be interfering with the game’s launch (we’ve had a lot of players who got foiled by overzealous antivirus systems).

Otherwise, it’s probably related to graphics. Try adding either of these as “launch options” for the game (r-click on “Fantasy Strike” in Steam > Properties > General > Set Launch Options):


This will try to run the game using OpenGL Core or DirectX 9, rather than the game’s default of DirectX 11, which may work better on your machine.

1 Like

No antivirus problem here.

Tried both launch options and OpenGL Core worked out.

I can play the game now. Thanks!

I think my system is pretty standard. I’ll let you know if future driver/software updates let’s me start the game with default settings.


Just an update. Whatever the original problem was, it disappeared with the latest update.