Linux noob here. Installed FS for linux, but it won't boot

Every time i press the ‘PLAY’ button the game tries to start, but nothing shows up. FS will show ‘Running’ in the Steam library, but the entire display simply shifts up and glitches a bit, hangs there for a while, and then comes back down and FS stops running.

I’m still relatively new to Linux overall. I recently installed Xubuntu 18.04 on an ssd, installed native Steam, and installed fantasy strike for linux for the first time. i5 2500k and nvidia GTX 1050. I will mention that I was messing with the driver in order to get DXVK working, but I couldnt figure it out and left it as is. Nvidia driver shows ver. 396.54.

Anyone willing to help me out?

Can you try launching the game in windowed mode by setting the game’s “Launch options” in Steam to -screen-fullscreen 0? This might be easier for your video drivers to handle.

If this still doesn’t work, can you give me the game’s log file? It’s at:
~/.config/unity3d/Sirlin Games/Fantasy Strike/Player.log

Thanks. I tried your first suggestion. The game did show a window, but there was nothing being displayed (it did that thing where your background ‘freezes’ in the window) and closed shortly after. I found the log, but I wasn’t sure if I could just dump the whole thing here so i found this temp hosting site and uploaded the log there.

Ah, I believe you’re an unfortunate victim of the current Unity bug where plugging in a Switch controller will crash on load:

The log file shows you have a Switch controller plugged in. That’s supposed to work, but right now, on Linux, it will always crash, sorry. It’s an issue with the game engine Unity, we’re waiting on them to fix it.

To work around that, you’ll need to unplug your Switch controller for now. (Some other controller types will work, but Hori and Switch controllers will crash.)

Interesting. That’s actually quite a relief! I was worried that I may have messed with stuff a little too much. Thank you much for your time.