Loss of internet connection on start-up

Loss of internet connection on start-up

Launching Fantasy Strike appears to cause my internet connection to flat-line

Steps to reproduce:

  1. Start the game

Expected Results:
A bit of fun getting bodied or bodying others.
Actual Results:
Sadness as my online applications suddenly drop off line.
I have tried a number of things to get to the bottom of this issue but it seems that Fantasy Strike is the only game that does this. This is a -new- bug as I’ve never had it do this before and I’m wondering if it has to do with a few ports that could be opened which I haven’t been successful with.
I would attach the Debug log or Output log but I’m not sure where that would go.
Game Version:
System Information:

That is interesting. I don’t think I have personally experienced this bug. However, if you want information on what ports Fantasy Strike uses you can find it here.

Solved. It appears that my onboard wi-fi antenna is shitty compared to the one that just broke. I guess FS is just too much data for it to handle at once? Switching to an ethernet cable has solved the issue. Unless it was the recent windows update but I -hiiiiiighly- doubt that.

I also doubt FS is the only game that would have caused this issue if I’d continued playing another online game.