Micro Stuttering

MOBO: Biostar TZ77B
CPU: i5-2500K CPU @ 3.30GHz × 4
GPU: GeForce GTX 750 Ti (driver 440.100)
OS: Linux Mint 20 Cinnamon (kernel 5.4.0-47-generic)

I’ve been getting occasional and seemingly random bouts of micro stuttering. When it happens, the in-game FPS counter stays at 60, but it looks noticeably choppy. It eventually goes away on its own after several minutes, or by pausing and going into the video options, turning VSYNC off, unpausing, repausing, and turning VSYNC back on. This seems to fix it every time (until it starts happening again).

This has been happening since I first started trying the game (early August) and persists through today’s patch. I’ve only ever tried playing Solo CPU matches so far.

I’ve tried messing with the other video options, turning off Steam Overlay, and turning on “Prefer Maximum Performance” in the Nvidia settings, but it has made no difference.

I’ve attached my log file from my last session. It started micro stuttering somewhere during my first game. It was my Onimaru against DeGrey. I played a round or two with the stutter, then did the VSYNC toggle fix I mentioned. It was fine for a few games (against Lum, Rook, Valerie, and Valerie again), then it started micro stuttering right at the start of the Setsuki match. The stuttering persisted through the Setsuki match and though the following Geiger match. The stuttering ceased somewhere in the middle of the Grave match. After finishing the Grave match, I exited the game and wrote this post.

Player.log: https://pastebin.com/vNQJW2uM


It seems that you don’t need to toggle vsync on and off: you can also temporarily fix the stutter by spamming the start button to bring up the pause menu a few times.

It feels like I’ve tried every combination of video settings in Linux Mint and Nvidia X Server. While I’ve found no way to make it better, I did find a way to make it worse: turning on “Force Composition Pipeline” or “Force Full Composition Pipeline” in the Advanced Display Config settings of Nvidia X Server will make the stutter near-constant.

I also experience this at times on Linux Mint, though I play with V-Sync off.

There was an nvidia driver update a couple days ago to version 450.66. It doesn’t seem to have affected this problem.