Steam In-home Streaming FS Does Not Accept Controller Inputs

Steam in-home streaming not working with controller inputs


When using Steam in-home streaming to play Fantasy Strike on a remote client, FS does not seem to accept any controller inputs. Other games with In-home streaming are working fine with controller inputs (including other fighting games like Rivals of Aether, Street Fighter IV, Divekick, etc). In my particular case I’m using a DualShock 4 on a Mac client streaming from a Windows host box. I have tried other controllers as well with no luck.

Steps to reproduce:

  1. Connect DS4 controller to computer. Steam Big Picture recognizes the controller and FS is set with DualShock 4 presets in Steam controller configuration.
  2. Load Fantasy Strike via streaming.

Expected Results:

Should be able to use existing controller configuration or long press two buttons to reconfigure the controller.

Actual Results:

No controller inputs at all seem to work. Keyboard and mouse input works OK.


I am unsure if this affects Steam Link or Nvidia Shield streaming. I have tried with multiple controllers (X360, 8bitdo SNES, Dualshock 4) and none seem to work. I realize this is early access but I figure this issue should be known.

Game Version: Steam Early Access

I had a similar problem
I solved by leaving only the Guide button focuses steam option checked

I tried your suggestion with streaming and it did not work. PS4 config options on or off made no difference. I turned it off on both host and client and no luck. As far as I can tell, the game is not playable via streaming with a controller. Keyboard inputs do work, but I’d prefer to use a gamepad.

If anyone has a Shield or Steam Link it would be useful to know if those are affected as well, or if anyone with multiple machines can try duplicating this.

I have a Steam Link and ran into this problem last night. I came here looking for a solution. After a little messing around, here’s what I did to get it working.


  • The Steam Link recognized both of my controllers, but FS only saw one.
  • In the in-game controller setup, holding two buttons only worked for the first controller (the only one that FS already recognized).
  • I was using wired X-Box 360 controllers. The initial recognized controller was an official X-Box product, whereas the second was a GameStop brand knockoff. I don’t think this would affect anything, however, full disclosure.


  1. I held the X-Box button on the unrecognized controller to take me back to Steam. Because Steam recognized this input, it was the only button I could use on that device.
  2. I exited the game and restarted it using that same controller.
  3. Once in the game, I held two buttons down to enter the controller setup. Then, I held down two buttons on the first (originally recognized) controller. Both worked!
  4. I entered button choices as usual and played two-player for the first time (and had my best fighting game experience in a long time… my friend’s, too.)

Controller Input Issues

  • I noticed that the control sticks and triggers both have the ability to read the pressure of the button press (the further/harder you press can trigger different actions, like walking to running in other games).
  • When I made the left control stick my character movement input, it was way less responsive than the D-Pad (my ultimate choice).
  • Both the control stick and triggers could sometimes register input when I didn’t want them too.
  • For example, when setting up a controller, the sequence has you enter your preferred OPTION key after choosing your R2 button (a trigger). When I first did this, it automatically registered the R2 as my OPTION key, after just pressing it for R2 because it was still detecting an input.
  • Similar with the control stick, it made it almost impossible to get a Yomi Counter (I confirmed this in Practice Mode numerous times) because the control stick was still registering input, even if i wasn’t touching it. Once changing movement controls to the D-Pad, that problem was solved, too.