Switch version not letting player 2 edit controlls ***when using gamecube adapter. edited for clarity***

Title: switch version not letting player 2 edit controlls when using gamecube adapter.

Summary: tried with both gamecube controllers with official nintendo adapte. Tried using GC for player 1 and joycon for player 2 as well. Only lets L and R be changed.

Steps to reproduce:

  1. start a local 2 player match
  2. open up menu try to edit controlls for player 2

Expected Results:
Player 2 should be able to edit.

Actual Results:
Player 2 can only edit l and r controlls. Tried with player 1 using gamecube controller and player 2 using joycon as well.



Game Version:
System Information:

Cannot reproduce. I tried using single joycons for p1 and p2. Tried in main menu, on character select screen of local versus (single match), and during gameplay of local versus. In all cases, p2 could set all their controls however they wanted.

Any more steps to reproduce with joycons?

I havent tried using ONLY joycons for player 1 and player 2.

I desperately want to use gamecube adapter so i can play with gamecube controller.

So i am guessing the gamecube controller adapter is causing an issue probably. I am not at home to test using only joycons though.

I edited the main post. Sorry for not being more specific at first

I want to note that when both players are using a gamecube controller the second controller works in a match, it just wont allow control edits.

I really hope for this. A lot of smash bros players can use this game as a stepping stone into fighting games and im sure many would wanna use gamecube controller.


Seems its its just finnicky and will not work properly everyonce and a while.

Is a mayflash adapter involved in this? There is a high correlation between controllers not working (in any Unity game) and mayflash hardware, as far as I can tell. In any case, it would be helpful to give exact specs or link to the specific hardware involved with the controller adapter.