Update causes game to freeze during loading on Linux

Title: Game freezes during initial loading screen

Summary: Since the game updated, I’ve been unable to play Fantasy Strike on my Linux PC. It invariably freezes between 1/3 to 1/2 of the way through the initial loading screen. I can’t even get to the main menu any more.

Steps to reproduce:

  1. Try to launch Fantasy Strike.

Expected Results: Seeing the main menu at some point.

Actual Results: Watching a static screen forever.

Notes: I very occasionally had a similar problem before the recent update, but killing the process and re-launching the game always took care of it. That doesn’t work any more.


Game Version: Steam

System Information: Intel i3-6100, Nvidia 1050 Ti, 16 GB RAM, Linux Mint

Problem solved, it seems. I know that the first thing any PC-gaming troubleshooter will tell you is “update your graphics drivers”. And yet in all my decades of PC gaming, I can honestly say that updating my graphics drivers has never once solved a problem for me. But there must be a first time for everything, because updating from Nvidia driver 460 to Nvidia driver 465 has got Fantasy Strike running on my Linux box again. Why a slightly out-of-date graphics driver should have caused the game to hang during the initial loading screen, I’ll never know. It seems improbable. Truly, graphics drivers are fell and mysterious things.