V0.9698 Setsuki is headless (on Mac)

Upon launch, Setsuki has no head if she appears on the home screen, character select, or in-game

Steps to reproduce:

  1. Launch game.
  2. See headless Setsuki.
  3. Cower in fear.

Expected Results:
Setsuki with a head.

Actual Results:
Setsuki with no head.

It’s creepy, but still technically playable.

Game Version:

System Information:


did you screenshot???
I wanna see!

Huh! I haven’t seen this particular bug on my own Mac setup. Sounds… memorable!

Since my mac is slow, I have to play on the lowest graphic settings and resolution. I wanted to get a screenshot of it in high resolution, but that fixed it! So this bug is only for us plebes with really pathetic computers.




New skin please

It’s Car Boys - Fantasy Strike edition. :smiley:

1 Like

“Rook, this changes EVERYTHING”

1 Like

Rook “Fuck you Jaina” Edition

I can confirm this bug exists, but I’d like to leave some notes on it.

  • We’ve seen it on Mac before, but never on Windows.
  • As far as I know, it has nothing to do with graphics quality settings, and can occur on high quality as well.
  • It’s a new piece of information to us that changing the graphics quality setting could even possibly change the state of her model from broken to working or vice versa.
  • The problem seems to occur far more frequently when we run the game internally, in our editor, but seems to be very rare when we make a standalone build, such as the ones we give to you.
  • When the problem does exist in a particular build, that’s new info (to me at least) that it could be broken on one person’s computer but not on a different person’s.

Does it only happen to Setsuki?

This just happened to me on the Free Weekend build (0.10211). It’s the only build I’ve played, and it does not happen consistently. (Can attach screenshots, but it basically looks like the ones above-- in the load screen Setsuki just has no head, during play she’s a vaguely triangular Cthuloid horror.)

1 Like

If you encounter this bug on Mac, you can quit the game and launch it again. Each launch seems to have a random chance of triggering the bug. We believe it to be a bug in Mac Unity itself. Perhaps later, when we upgrade to a newer version of Unity, it will be fixed. I hope that does it.

I ran into this same issue with Setsuki and Valerie

Reboot eventually fixed Setsuki but no luck on Valerie so far.

OSX 10.12.2 [ Sierra ]
Fantasy Strike version 0.11177

The issue with Setsuki in Mac builds is claimed fixed in the wild west branch (not yet in the public steam branch). Since the claimed fix, I DID see the issue one time with Setsuki in the editor we use internally. So maybe not fixed…but I would have expected to see it something like 100 times over the weeks involved, so maybe it’s 100x less likely. I have not seen Setsuki broken in a build since the claimed fix. (Again, remember the fix isn’t in the public Steam branch at the time of this writing, but will be within a week.)

Valerie’s issue is not even claimed fixed in any Mac version. It’s been well-known to use for many weeks, but we don’t have a fix yet.

When encountering either issue, each time you restart the game, it seems to give you a random chance that the issue is fixed.

Sounds good, thank you for the update !